ZSwitch: Some Inbound Caller ID showing "UNKNOWN"
Incident Report for 2600hz
Resolved
This issue has been identified and is now resolved.
Posted Feb 26, 2021 - 07:00 PST
Investigating
We are investigating reports that some inbound Caller ID names are showing "Unknown"
Posted Feb 26, 2021 - 06:59 PST
This incident affected: Telephony Services.