This was mistakenly scheduled for today - We won’t be carrying out this change until the 1st of March.
Posted Feb 21, 2025 - 07:23 PST
Completed
The scheduled maintenance has been delayed until the 1st of March.
Posted Feb 21, 2025 - 02:00 PST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 21, 2025 - 00:00 PST
Scheduled
We will be making a change on Zswitch to increase the required password complexity on accounts. They will need to meet the current criteria going forward -
Minimum password length is 12 characters At least one lower case character is required At least one upper case character is required At least one digit is required At least one special character is required
Passwords will also expire after 365 days.
Posted Feb 13, 2025 - 06:04 PST
This scheduled maintenance affected: Telephony Services and Support Portal.