Cloudflare appears to have stopped advertising our 8.X addresses causing this outage; we have now re-enabled them. We're working with CloudFlare to investigate the root cause but are seeing issues resolve from our side.
Posted Feb 20, 2026 - 10:35 PST
Update
This appears to a problem with Level3 currently; our infrastructure team is investigating implementing routing changes to workaround the issue.
Posted Feb 20, 2026 - 10:15 PST
Investigating
We are currently investigating Zabbix alerts/reports of outages affecting portal/calls. We will send out an update as ASAP.
Posted Feb 20, 2026 - 10:09 PST
This incident affected: Telephony Services, Management Portal, Advanced Provisioner, and Cluster Manager.