Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 19, 2025 - 19:00 PST
Scheduled
2600Hz Operations will be performing some more intrusive debugging on one of our SBCs located in the US-Central region. We expect no impact for most of this maintenance, but it is possible that degraded service may occur due to the nature of the work being done.
Thank you, 2600Hz Operations
Posted Nov 17, 2025 - 08:38 PST
This scheduled maintenance affected: Telephony Services.