Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 30, 2026 - 23:00 PDT
Scheduled
We will be performing a scheduled maintenance to upgrade TrunkingIo components across our US-based ZSwitch cluster. This update includes enhancements and fixes to improve overall system stability and maintain compatibility between services.
During the maintenance window, customers may experience:
Temporary interruption of telephony services during service restarts Active calls may drop while services are being restarted on individual nodes Brief unavailability of API and UI functionality during the upgrade process
Services will automatically restore once each node completes its upgrade and associated services are restarted.
Posted Mar 26, 2026 - 11:48 PDT
This scheduled maintenance affected: Telephony Services.